NVMe導入

毎年恒例の年末のPC掃除をしました。現在使用中のメインPCは2014年末に構築したもので、Windows7からWindows10にUpgradeしたもの。
Windows10へのOSアップグレード+WindowsUpdateによる設定のゴミがちょいちょい謎挙動を引き起こしてくれるため、SSDの交換がてらOS再インストールをしました。

謎挙動の内容として一番迷惑なのがスリープからの勝手な復帰とフリーズのような動作。

スリープからの勝手な復帰は、いろいろ設定しても決まった時間(日中)に勝手に起きていたようなので、イベントログからタスクに原因がありそうと判断。タスクスケジューラを調べたら、MediaCenterUpdateが、exeが存在しないのにタスクだけ動いていてこいつが悪さをしていました。タスクを無効化してこれで問題は解決していたのですが、今後もWindowsUpdateのタイミング等で設定が外れることなども勘案すると、クリーンインストールし直した方がよいかと考えました。

フリーズのような動作は、構築時から無交換のSSDが寿命かも?ということで、こちらも併せて交換することに。で、今回交換したのはこちら。


Intel Solid-State Drive 750 SERIES。勿論NVMe接続のAdd-InCardの方です。自分的に初物なのでIntelのサイトで情報を集めてドライバなどを入手して準備完了。
それにしても、Intelのサイトの機械翻訳のわかりにくいこと。英文そのままの方がわかりやすいです…

さて、Add-Inカードのインストールですが、PICeの接続場所がCPUに近いほど、遅延が少なく高速になるので最もCPU寄りのPCIeレーンにさくっと接続しました。
続いて、Windows10のクリーンインストールは爆速完了。OSインストール自体は10分で完了です。Windows10のインストール媒体を最新とするべく、インストール直前に作成したり、インストール先の選択時にIntelのNVMeドライバを指定することを忘れなければ問題ないですね。(MicrosoftのWindows10標準ドライバでもいけるみたいですが、性能がフルに出ないという記事も見つけたので…)

次に更新プログラムの導入ですが、これが意外にトロい。WindowsUpdateに小一時間。追加で必要なAPPの再インストールに30分程度。これでPCがほぼ利用可能な状態になりました。とりあえずCrystalDiskMark 5.2.0 x64で計測。SSD以外の構成は一切変更なし。

○基本構成
MB:ASUS X99-E WS(BIOS:0606)
OS:Windows10Pro(NVMeドライバはIntelのものをクリーンインストール時に導入)

○換装前
ADATA Premier Pro SP900 256GB
SATA 6Gb/s接続
Sequential Read (Q= 32,T= 1) :   538.534 MB/s
Sequential Write (Q= 32,T= 1) :   194.184 MB/s
Random Read 4KiB (Q= 32,T= 1) :    69.277 MB/s [ 16913.3 IOPS]
Random Write 4KiB (Q= 32,T= 1) :   159.886 MB/s [ 39034.7 IOPS]

○換装後
Intel SSD 750 400GB HHHL
PCI Express 3.0 x4接続
Sequential Read (Q= 32,T= 1) :  2360.594 MB/s
Sequential Write (Q= 32,T= 1) :   892.278 MB/s
Random Read 4KiB (Q= 32,T= 1) :   485.656 MB/s [118568.4 IOPS]
Random Write 4KiB (Q= 32,T= 1) :   423.427 MB/s [103375.7 IOPS]

ベンチ上の速度は文句なし。相手にならないですねぇ、これ。Writeの数字が若干疑問ですが、この手のベンチマークソフトの癖なのかどうなのかよくわかりません。と、別の日記に書いたら、知人に「シーケンシャルでWriteCacheがあふれたか、利いていない感じでしょうかね。」と指摘されたので確認してみると…

確かに。で、設定を変えようとするのですが、

だめっぽかったです。

カタログ見直してみると、ほぼカタログ値が出ているのと、イベントログにも問題は見られずSSD管理ツールでもエラーなしなので問題ないと判断して放置することにしました。

インストール後、スリープから復帰時に電源が落ちてしまう現象が出たのでちょっと調べて、イベントログなどからおそらくSSDを見失っているのだろうと推測。PCIeの省電力コントロールがなぜか無効になっていたので、自動選択に戻してからはスリープ復帰に失敗しなくなっているのでおそらく解決。
最後に、プチフリーズな動作をするときが。原因がSSDあると特定できてないので勘違いの可能性もあり。SSD由来にしてはちょっと挙動が?なので。もうちょっと様子見です。

 

<追記>

スリープから復帰時に電源が落ちてしまう現象は改善していませんでした…。KP41じゃなさそう。

 

“NVMe導入” への 1 件のフィードバック

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です